20 lines
305 B
Nix
20 lines
305 B
Nix
{ config, pkgs, ... }:
|
|
|
|
{
|
|
networking = {
|
|
wireless = {
|
|
enable = true;
|
|
networks = {
|
|
"your-SSID" = {
|
|
psk = "your-wifi-password";
|
|
};
|
|
};
|
|
};
|
|
firewall = {
|
|
enable = true;
|
|
allowedTCPPorts = [ 22 ]; # Allow SSH
|
|
};
|
|
useDHCP = true;
|
|
};
|
|
}
|